Configuración de una red EIGRP


Utilizaremos el programa del packet tracert para realizar la práctica.

EIGRP (propiedad de Cisco) tiene las siguientes características y funciones:
1. Protocolo de vector de distancia con clase aunque actué como protocolo de estado de enlace.
2. Métrica: ancho de banda, retraso, confiabilidad y carga.
3. Algoritmo de Actualización por Difusión (DUAL), se utiliza para seleccionar los caminos sin bucles.
– Determinación de ruta: se elige un Sucesor (router principal) y un Sucesor Factible (FS, router de respaldo), para ello se almacenan las rutas principales y alternativas en las tablas de enrutamiento utilizando tanto la tabla de vecinos como la de topología (por los cambios que se produzcan en toda la red).
No realiza actualizaciones periódicas, solo las actualizaciones de cambios de topología.
– Se utiliza el protocolo Hello para descubrir vecinos por medio de direcciones multicast 224.0.0.10
4. Mantiene tres tablas: vecinos, topología y enrutamiento.
5. RTP, para garantizar la entrega correcta y ordenada de la información y las actualizaciones de la tabla de enrutamiento.

Conectaremos dos redes distintas (la 192.168.1.0 y la 192.168.2.0) atravesando para ello, tres routers, en el cual se podra apreciar mejor el funcionamiento del protocolo de enrutamiento dinámico EIGRP de Cisco.

image

Calculo de las redes para las seriales:

212.212.212.000000 00 Utilizaremos esta red, con mascara /30, por lo que cogemos dos bits (4 direcciones posibles, descartamos el de subred y el de mascara de red, quedando dos direcciones para asignar)

212.212.212.000001 00  –> 212.212.212.4 – 212.212.212.7
212.212.212.000010 00  –> 212.212.212.8 – 212.212.212.11
212.212.212.000011 00  –> 212.212.212.12 – 212.212.212.15
212.212.212.000100 00  –> 212.212.212.16 – 212.212.212.19


Configuramos el Router0:

Parte LAN
Router(config)#interface fastEthernet 0/0  Interfaz del Gateway de los PCs.
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown

Parte Serial
Router(config)#interface serial 0/3/0  Punto a punto con el router1
Router(config-if)#ip address 212.212.212.9 255.255.255.252
Router(config-if)#clock rate 56000 Interfaz DCE
Router(config-if)#no shutdown

EIGRP
Router(config)#router eigrp 2  Sistema autonomo elegido, el 2

Anunciamos nuestras propias dos redes, que tiene el router:
Router(config-router)#network 212.212.212.8
Router(config-router)#network 192.168.1.0

Router(config-router)#no auto-summary

 

Configuramos el Router1:

Parte Serial
Router(config)#interface serial 0/3/0   Punto a punto con el router0
Router(config-if)#ip address 212.212.212.10 255.255.255.252
Router(config-if)#no shutdown

Router(config)#interface serial 0/3/1  Punto a punto con el router2
Router(config-if)#ip address 212.212.212.13 255.255.255.252
Router(config-if)#clock rate 56000   Interfaz DCE
Router(config-if)#no shutdown

EIGRP
Router(config)#router eigrp 2  Sistema autonomo elegido, el 2

Anunciamos nuestras propias dos redes, que tiene el router:
Router(config-router)#network 212.212.212.9
Router(config-router)#network 212.212.212.12

Router(config-router)#no auto-summary


Configuramos el Router2:

Parte Serial
Router(config)#interface serial 0/2/0  Punto a punto con el router1
Router(config-if)#ip address 212.212.212.14 255.255.255.252
Router(config-if)#no shutdown

Parte LAN
Router(config)#interface fastEthernet 0/0  Interfaz del Gateway de los PCs.
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#no shutdown

EIGRP
Router(config)#router eigrp 2  Sistema autonomo elegido, el 2

Anunciamos nuestras propias dos redes, que tiene el router:
Router(config-router)#network 212.212.212.12
Router(config-router)#network 192.168.2.0

Router(config-router)#no auto-summary

Al terminar de configurar el EIGRP:

Por ejemplo, si queremos ver las redes aprendidas en el router 1:

Router#sh ip route
D – EIGRP  C – connected

D    192.168.1.0/24 [90/2172416] via 212.212.212.9, 00:04:39, Serial0/3/0
D    192.168.2.0/24 [90/2172416] via 212.212.212.14, 00:03:31, Serial0/3/1
212.212.212.0/30 is subnetted, 2 subnets
C       212.212.212.8 is directly connected, Serial0/3/0
C       212.212.212.12 is directly connected, Serial0/3/1

Realizamos un ping de un PC de a red 192.168.1.0 a la 192.168.2.0 y llega exitosamente
ping 192.168.2.1

Pinging 192.168.2.1 with 32 bytes of data:

Reply from 192.168.2.1: bytes=32 time=188ms TTL=125
Reply from 192.168.2.1: bytes=32 time=144ms TTL=125
Reply from 192.168.2.1: bytes=32 time=187ms TTL=125
Reply from 192.168.2.1: bytes=32 time=172ms TTL=125

Ping statistics for 192.168.2.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 144ms, Maximum = 188ms, Average = 172ms

Autenticación EIGRP entre routers

Es una autenticación mutua entre ambos, permitiendo que ningún router no autenticado, actualice de forma incorrecta un  router.

image

Router0 y 1
Router(config)#key chain alas  Nombre del key chain
Router(config-keychain)#key 2345   contraseña

Router(config)#interface serial0/3/0
Router(config-if)#ip authentication mode eigrp 2 md5

Anuncios

4 Respuestas a “Configuración de una red EIGRP

  1. Ahí AhÍ!! A estudiar!!! 😛

  2. Mierda no se pueden editar comentarios anonimos xD

  3. hola.no tienes el ejercicio hecho, por favor??

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s