Configuración OSPF en una sola Área


OSPF – Primero la ruta libre mas corta
– Protocolo por estado de enlace
– Publicaciones de ruta (LSA) de multidifusión a TODOS los routers de la misma área
– Algoritmo SPF (Dijkstra) para calcular la ruta mas corta
– Utilización del protocolo Hello para determinar que interfaces reciben las publicaciones de estado de enlace. Lo intercambian los routers vecinos.
– Soporta VLSM
– Autenticación de origen de ruta
– Convergencia rápida

image

Configuracion de Router0:

Parte LAN
Router(config)#interface fastEthernet 0/0 Interfaz del Gateway de los PCs.
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown

Parte Serial
Router(config)#interface serial 0/3/0 Punto a punto con el router1
Router(config-if)#ip address 212.212.212.9 255.255.255.252
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown

Configuración OSPF
Router(config)#router ospf 100  ID de proceso <1-65535>
Router(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router(config-router)#network 212.212.212.8 0.0.0.3 area 1


Configuracion de Router1:

Parte Serial
Router(config)#interface serial 0/3/1   Punto a punto con el router0
Router(config-if)#ip address 212.212.212.10 255.255.255.252
Router(config-if)#no shutdown

Router(config)#interface serial 0/3/0  Punto a punto con el router2
Router(config-if)#ip address 212.212.212.13 255.255.255.252
Router(config-if)#clock rate 56000   Interfaz DCE
Router(config-if)#no shutdown

Configuración OSPF
Router(config)#router ospf 100 ID de proceso <1-65535>
Router(config-router)#network 212.212.212.9 0.0.0.255 area 1
Router(config-router)#network 212.212.212.12 0.0.0.3 area 1


Configuracion de Router2:

Parte Serial
Router(config)#interface serial 0/3/0 Punto a punto con el router1
Router(config-if)#ip address 212.212.212.14 255.255.255.252
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown

Parte LAN
Router(config)#interface fastEthernet 0/0   Interfaz del Gateway de los PCs.
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#no shutdown

Configuración OSPF
Router(config)#router ospf 100
Router(config-router)#network 212.212.212.12 0.0.0.3 area 1
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1


Monitorizacion de OSPF

Router#show ip route
Codes: C – connected,  O – OSPF

Gateway of last resort is not set  Entradas por OSPF aprendidas

O    192.168.1.0/24 [110/65] via 212.212.212.9, 00:05:58, Serial0/3/1
O    192.168.2.0/24 [110/65] via 212.212.212.14, 00:03:45, Serial0/3/0
212.212.212.0/30 is subnetted, 2 subnets
C       212.212.212.8 is directly connected, Serial0/3/1
C       212.212.212.12 is directly connected, Serial0/3/0

Router#show ip protocols Muestra los protocolos utilizados en el router

Routing Protocol is “ospf 100”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 212.212.212.13
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
212.212.212.0 0.0.0.255 area 1
212.212.212.12 0.0.0.3 area 1
Routing Information Sources:
Gateway         Distance      Last Update
212.212.212.9        110      00:20:52
212.212.212.13       110      00:19:00
212.212.212.14       110      00:18:37
Distance: (default is 110)

Router#show ip ospf interface Muestra las adyacencias, estado del router y los intervalos hello de las interfaces que participan en el mismo proceso

  • Serial0/3/0 is up, line protocol is up
    Internet address is 212.212.212.13/30, Area 1
    Process ID 100, Router ID 212.212.212.13, Network Type POINT-TO-POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0 No hay DR y BDR en esta red
    No designated router on this network
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 Los tiempos de Hellos y muerte (tiempo que hay que esperar para ver que el router no responde)
    Hello due in 00:00:08
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1 , Adjacent neighbor count is 1 Tiene una adyacencia con el router de al lado (con direccion 212.212.212.14)
    Adjacent with neighbor 212.212.212.14
    Suppress hello for 0 neighbor(s)
  • Serial0/3/1 is up, line protocol is up
    Internet address is 212.212.212.10/30, Area 1
    Process ID 100, Router ID 212.212.212.13, Network Type POINT-TO-POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
    No designated router on this network
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
    Index 2/2, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 212.212.212.9
    Suppress hello for 0 neighbor(s)
  • FastEthernet0/0 is up, line protocol is up La tenemos como red multiacceso con dos PCs
    Internet address is 192.168.2.254/24, Area 1
    Process ID 100, Router ID 212.212.212.14, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State DR, Priority 1 Esta interfaz tiene de DR  la red 212.212.212.14
    Designated Router (ID) 212.212.212.14, Interface address 192.168.2.254
    No backup designated router on this network

Router# show ip ospf neighbor ID de los routers vecinos del router1, su prioridad, el estado, direccion IP e interfaz de conexion

Neighbor ID     Pri   State           Dead Time   Address         Interface
212.212.212.9     0   FULL/  –        00:00:38    212.212.212.9   Serial0/3/1
212.212.212.14    0   FULL/  –        00:00:31    212.212.212.14  Serial0/3/0


Elección de un DR y BDR

En redes punto a punto, se detecta dinamicamente a sus vecinos enviando paquetes Hello con la direccion de multidifusion 224.0.0.5. No se lleva a cabo elección de DR o BDR. Solo ocurre en redes mutiacceso.

Si queremos que un determinado router sea DR y otro BDR según interfaz, se define mediante.
– Valor de prioridad mas alto
Router(config)#interface serial 0/3/1
Router(config-if)#ip ospf priority 200
– ID del Router, con la direccion IP mas alta
– Interfaz virtual o loopback

Router(config)#interface loopback100
Router(config-if)#ip address 200.200.200.2 255.255.255.252


Autenticación

Contraseña de autenticacion en texto simple, para cada enlace de un router y otro, introducimos una contraseña (la misma o distinta) para que no se pueda incorporar un router entre medias para robar información.
Router(config)#interface serial 0/3/1
Router(config-if)#ip ospf authentication-key ola


Ajuste de los temporizadores

Por defecto, Hello es de 10 segundos y el de dead es de 40 segundos. Tienen que ser iguales los parametros en TODOS los routers.
Router(config)#interface serial 0/3/1
Router(config-if)#ip ospf hello-interval 20
Router(config-if)#ip ospf dead-interval 50

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s