OSPF de Múltiples Áreas


OSPF tiene la capacidad de dividir un AS (sistema autónomo) en redes mas pequeñas llamadas áreas.
Las actualizaciones y el recálculo de la topología se producen dentro de cada área. Esto hace que los cálculos SPF solo afecten a un solo área, excluyendo a las demás.

Se puede publicar entre áreas las rutas resumidas, en vez de una por red. La propagación de rutas resumidas lo realiza el LSU (actualizaciones de estado de enlace)

En estas topologías OSPF de múltiples áreas quedan definidos tres tipos de routers:
Router Interno: todas las interfaces en la misma área
Router de Backbone: conectada una interfaz al área 0 (área de backbone)
Router Fronterizo o ABR: tienen interfaces conectadas a diferentes áreas.

Esta configuración que vamos a realizar, crearemos una red multiacceso que no contiene ningún router fronterizo.

image

Configuración del router HUELVA:

Hacia el área 10
HUELVA(config)#interface fastEthernet 0/0  Interfaz del área 10 (RED: 192.168.1.0/24)
HUELVA(config-if)#ip address 192.168.1.1 255.255.255.0
HUELVA(config-if)#no shutdown

Hacia el área 0
HUELVA(config)#interface fastEthernet 0/1 Interfaz del área 0, backbone (RED: 200.4.1.0/24)
HUELVA(config-if)#ip address 200.4.1.1 255.255.255.0
HUELVA(config-if)#no shutdown

Configuración OSPF
HUELVA(config)#router ospf 100
HUELVA(config-router)#network 192.168.1.0 0.0.0.255 area 10
HUELVA(config-router)#network 200.4.1.0 0.0.0.255 area 0

Configuración del router MADRID:

Hacia el área 30
MADRID(config)#interface fastEthernet 0/0 Interfaz del área 30 (RED: 192.168.2.0/24)
MADRID(config-if)#ip address 192.168.2.1 255.255.255.0
MADRID(config-if)#no shutdown

Hacia el área 0
MADRID(config)#interface fastEthernet 0/1  Interfaz del área 0 (RED: 200.4.1.0/24)
MADRID(config-if)#ip address 200.4.1.2 255.255.255.0
MADRID(config-if)#no shutdown

Configuración OSPF
MADRID(config)#router ospf 200
MADRID(config-router)#network 192.168.2.0 0.0.0.255 area 30
MADRID(config-router)#network 200.4.1.0 0.0.0.255 area 0

Configuración del router GRANADA:

Hacia el área 20
GRANADA(config)#interface serial  0/3/0 Interfaz del área 20 (RED: 212.212.212.8/30)
GRANADA(config-if)#ip address 212.212.212.9 255.255.255.252
GRANADA(config-if)#clock rate 56000
GRANADA(config-if)#no shutdown

Hacia el área 0
GRANADA(config)#interface fastEthernet 0/1 Interfaz del área 0 (RED: 200.4.1.0/24)
GRANADA(config-if)#ip address 200.4.1.3 255.255.255.0
GRANADA(config-if)#no shutdown

Configuración OSPF
GRANADA(config)#router ospf 300
GRANADA(config-router)#network 200.4.1.0 0.0.0.255 area 0
GRANADA(config-router)#network 212.212.212.8 0.0.0.3 area 20

Configuración del router ALMERIA:

Hacia el área 20
ALMERIA(config)#interface serial 0/3/0  Interfaz del área 20 (RED: 212.212.212.8/30)
ALMERIA(config-if)#ip address 212.212.212.10 255.255.255.252
ALMERIA(config-if)#no shutdown

Configuración OSPF
ALMERIA(config)#router ospf 400
ALMERIA(config-router)#net
ALMERIA(config-router)#network 212.212.212.8 0.0.0.255 area 20

Monitorización del OSPF

MADRID#show ip protocols

Routing Protocol is “ospf 200”   Muestra el numero de proceso del ospf
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 200.4.1.2    Dirección mas alta del router, representando la ID
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.2.0 0.0.0.255 area 30
200.4.1.0 0.0.0.255 area 0
Routing Information Sources:
Gateway         Distance      Last Update
200.4.1.1            110      00:12:39
200.4.1.2            110      00:12:39
212.212.212.9        110      00:07:34
Distance: (default is 110)

MADRID#show ip ospf interface

  • FastEthernet0/0 is up, line protocol is up    Interfaz hacia el área 30
    Internet address is 192.168.2.1/24, Area 30
    Process ID 200, Router ID 200.4.1.2, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 200.4.1.2, Interface address 192.168.2.1 Es el DR para la interfaz 192.168.2.1
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 0, Adjacent neighbor count is 0
    Suppress hello for 0 neighbor(s)
  • FastEthernet0/1 is up, line protocol is up     Interfaz hacia el área 0
    Internet address is 200.4.1.2/24, Area 0
    Process ID 200, Router ID 200.4.1.2, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 200.4.1.1, Interface address 200.4.1.1 Es el DR para la interfaz 200.4.1.1
    Backup Designated Router (ID) 200.4.1.2, Interface address 200.4.1.2 Es el DR para la interfaz 200.4.1.2
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
    Index 2/2, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 2, Adjacent neighbor count is 2 Tiene dos routers vecinos
    Adjacent with neighbor 200.4.1.1  (Designated Router)
    Adjacent with neighbor 212.212.212.9
    Suppress hello for 0 neighbor(s)

MADRID#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
200.4.1.1         1   FULL/DR         00:00:35    200.4.1.1       FastEthernet0/1
212.212.212.9     1   FULL/DROTHER    00:00:39    200.4.1.3       FastEthernet0/1

La interfaz de madrid hacia el multiacceso, es el DR. Para la interfaz de granada hacia la red, es otro DR.image

MADRID#show ip route
Codes: C – connected, O – OSPF, IA – OSPF inter area

Gateway of last resort is not set

O IA 192.168.1.0/24 [110/2] via 200.4.1.1, 00:41:15, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
C    200.4.1.0/24 is directly connected, FastEthernet0/1
212.212.212.0/30 is subnetted, 1 subnets
O IA    212.212.212.8 [110/65] via 200.4.1.3, 00:36:01, FastEthernet0/1

Anuncios

3 Respuestas a “OSPF de Múltiples Áreas

  1. La wildcard de configuramiento OSPF del router Almeria deberia ser 0.0.0.3 ya que la direccion de red es /30

  2. gracias 🙂 me sirvio mucho

  3. es LSA no LSU

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s