Configuración de una red Frame-Relay Estático


Se envían datos sobre la red pública de datos, orientado a la conexión de alto rendimiento y eficacia. Delegando en la capa uno y dos del modelo OSI.

Define solamente la conexión entre la red de un proveedor de servicio y el dispositivo de un usuario.

Hay que tener en cuenta una serie de conceptos:
  – Datos de Equipo:
        o DTE: Equipo del cliente 
        o DCE: equipo propiedad del proveedor
  – Datos de Circuito:
        o PVC: Circuito Virtual Permanente 
        o SVC: Circuito Virtual Conmutado (se interrumpe cuando se acaba la comunicación, utilizado en transmisiones de datos esporádicas).
        o DLCI: Identificador de conexión a nivel local (no tiene importancia mas alla del enlace único) del PVC o SVC en una red Frame-Relay. Los DLCI los asigna la compañía telefónica.
        o CIR: Velocidad de información suscrita. Velocidad que transferirá en condiciones normales, con un promedio sobre un incremento de tiempo mínimo.
        o LMI: Interfaz de Administración Local. Verifica los datos que fluyan, tiene un mecanismo de multicast, direccionamiento global (proporciona a los DLCI significado global en vez de local) y un mecanismo de estado. Proporcionando un informe de estado constante sobre los DLCI que el switch conozca.
   – Tipo de Subinterfaces:
         o Punto a Punto: cada subinterfaz establece una conexión PVC punto a punto con el router remoto.
         o Multipunto: una subinterfaz establece múltiples conexiones PVC a varias interfaces físicas o subinterfaces de los routers remotos. En este modo, se utiliza el Horizonte Dividido para evitar bucles de enrutamiento (la información de los routers no saldrá por la misma interfaz que se recibió la información)

Funcionamiento de una Frame-Relay

Se identifican los routers que están conectados a la interfaz con el DLCI local.
A través de paquetes de ARP Inverso, se obtiene la dirección IP correspondiente a cada circuito virtual. Se envían estos mensajes cada 60 segundos.

Los routers están conectados a la nube Frame-Relay a través de un CSU/DSU (no hay nada analógico puesto que todo es digital por los circuitos virtuales).
El switch Frame-Relay informa a los routers remotos, los DLCI locales de los PVC (Circuitos Permanentes). Por cada DLCI activo los routers envían un paquete ARP inverso que contiene la dirección IP correspondiente a cada Circuito.
Los routers remotos crean tablas que incluyen los DLCI locales y las direcciones IP.

– Encapsulación cisco/IETF(cuando hay routers NO cisco)
  encapsulacion frame-relay [cisco/ietf]

– Configuración del LMI
  frame-relay lmi-type [cisco|anci|q933a]

– Subinterfaces Frame-Relay
  Varios PVC en una sola conexión física. En cada subinterfaz, le configuramos la encapsulación frame-relay correspondiente y seleccionamos si será punto a punto o multipunto (lo veremos en las siguientes entradas).

CONFIGURACION DE LA FRAME-RELAY EN EL PACKET TRACERT

Pinchamos dos routers que estarán conectados mediante una nube (Cloud-PT), la primera nube genérica del programa, que estará con los puertos y las interfaces configuradas.

Conectamos los routers a la nube mediante cables DCE o DTE a la nube.

Entramos en la configuración de la nube, en interfaces y los Seriales 0 y 1, añadiendo lo siguiente:
Configuracion del puerto Serial0 Configuracion del puerto Serial1
Lo que hemos hecho, es que al puerto Serial0 de la nube, estará conectado el circuito con un DLCI de 110. En el puerto Serial1, estará conectado el circuito con un DLCI de 100. Ambos con un LMI tipo Q933a (este parámetro también lo configuraremos en el router, aunque según que versiones no será necesario).

Vamos a la conexión Frame-Relay y añadimos el circuito del Serial0 al Serial1:
configuracion FR

Por lo general, los DCE son la nube Frame-Relay, y los DTE los routers, pero si no esta de esa forma no pasa absolutamente nada, siempre y cuando, si un router esta configurado como DCE, poner el parámetro de clock rate.

Así, que nuestro esquema de dibujo, sera el siguiente, donde conectaremos a cada extremo del circuito, un ordenador, con su respectiva IP de la red correspondiente.
La nube de Frame-Relay (que son los SW Frame-Relay) son los DCE y los routers los DTE.

FR

Configuración del ORIGEN

ORIGEN(config)#interface serial 0/0/0
ORIGEN(config-if)#encapsulation frame-relay ietf tipo de encapsulacion frame-relay (ietf | cisco)
ORIGEN(config-if)#ip address 10.16.0.1 255.255.255.0
ORIGEN(config-if)#bandwidth 64 configuramos el ancho de banda del circuito (ambos extremos)
ORIGEN(config-if)#frame-relay lmi-type q933a establece la conexion LMI (ansi | cisco | q933a)
ORIGEN(config-if)#frame-relay map ip 10.16.0.2 110 broadcast  frame- relay estático
ORIGEN(config-if)#no shutdown

ORIGEN(config)#interface fastEthernet 0/0
ORIGEN(config-if)#ip address 192.168.1.254 255.255.255.0
ORIGEN(config-if)#no shutdown

Configuración del DESTINO
REMOTO(config)#interface serial 0/0/0
REMOTO(config-if)#encapsulation frame-relay ietf tipo de encapsulacion frame-relay (ietf | cisco)
REMOTO(config-if)#ip address 10.16.0.2 255.255.255.0
REMOTO(config-if)#bandwidth 64  configuramos el ancho de banda del circuito (ambos extremos)
REMOTO(config-if)#frame-relay lmi-type q933a establece la conexion LMI (ansi | cisco | q933a)
REMOTO(config-if)#frame-relay map ip 10.16.0.1 100 broadcast frame- relay estático
REMOTO(config-if)#no shutdown

REMOTO(config)#interface fastEthernet 0/0
REMOTO(config-if)#ip address 192.168.2.254 255.255.255.0
REMOTO(config-if)#no shutdown

Para que las dos redes se comuniquen, podemos poner un enrutamiento dinámico o estático:
REMOTO(config)#ip route 192.168.1.0 255.255.255.0 10.16.0.1
ORIGEN(config)#ip route 192.168.2.0 255.255.255.0 10.16.0.2

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s